Difference between revisions of "Cloud Payroll - Error “This leave does not have any approver” when employee apply E-Leave"

From AutoCount Resource Center
Jump to navigation Jump to search
(Created page with "'''Question :''' My employee use E-leave to apply leave, system prompted an error “This leave does not have any approver”. System already have default setting for leave ap...")
 
 
Line 1: Line 1:
'''Question :''' My employee use E-leave to apply leave, system prompted an error “This leave does not have any approver”. System already have default setting for leave approval. Why still block for apply?
+
'''Question :'''AA use E-leave to apply leave, system prompted an error: This leave does not have any approver. Why is this happened as I have set the approval setting?
   
[[File:No approver1.png]]
+
[[File:Error_NoApprover_1.png |800px]]
   
   
 
<u><b>Possible Reason :</b></u>
 
<u><b>Possible Reason :</b></u>
   
You have created another departments/sub-department and this employee is falls under newly created department while in default Leave Approval setting is only set for Default department.
+
1. This employee is assigned to a newly created departments/sub-department which was not included in Leave Approval setting.
   
  +
2. Leave approver setting is for number of days ranging from 1.0 but the employee is applying for half day leave (0.5 day).
   
<u><b>Solution :</b></u>
 
   
 
<u><b>Solution 1:</b></u>
You must edit the Leave Approval setting.<br/><br/>
 
   
  +
Edit the Leave Approval setting to include the new departments if your company practises one approver to approve all employees’ application.<br/><br/>
1) Go to <span style='color:red'>Tools > Approval Setting</span>. Select (click to highlight) a <span style='color:red'>Leave Approval</span> setting and click <span style='color:red'>Edit</span> or you may just click on its title in the first column.
 
   
 
1) Go to <span style='color:red'>Tools > User Setting > Approval Setting</span>. Click on <span style='color:red'>Edit </span>button.
[[File:No approver2.png]]
 
  +
  +
[[File:Error_NoApprover_2.png |800px]]
   
   
 
2) Check to select departments and/or sub-departments then click on <span style='color:red'>Save</span>.
 
2) Check to select departments and/or sub-departments then click on <span style='color:red'>Save</span>.
   
[[File:No approver3.png]]
+
[[File:Error_NoApprover_3.png |600px]]
  +
  +
  +
<b>OR</b>
  +
Create/add a new leave approval if your company practises different approvers to approve different departments.
  +
  +
1) Go to <span style='color:red'>Tools > User Setting > Approval Setting</span>. Click on <span style='color:red'>Add New </span>button.
  +
  +
[[File:Error_NoApprover_4.png |800px]]
  +
  +
  +
2) Check to select departments and/or sub-departments then click on <span style='color:red'>Save</span>.
  +
  +
[[File:Error_NoApprover_5.png |600px]]
  +
  +
  +
  +
  +
<u><b>Solution 2:</b></u>
  +
  +
1) Go to <span style='color:red'>Tools > User Setting > Approval Setting</span>. Click on <span style='color:red'>Edit </span>button.
  +
  +
2) Change the Range From Day to 0 then click on <span style='color:red'>Save </span> button.
  +
  +
[[File:Error_NoApprover_6.png |600px]]
  +
   
   
3) Employee shall able to apply E-leave after you added the approval setting by department.
 
   
   
Line 30: Line 56:
   
   
By : Aisyah 181108, Lay Swan 181213, P181214
+
By : Aisyah 181108, Lay Swan 181213, P181214<br/>
  +
<b>Updated by Aisyah 200713, Azirah 200714, P200727</b>
   
 
{{NavigateForUser}}
 
{{NavigateForUser}}

Latest revision as of 05:09, 28 July 2020

Question :AA use E-leave to apply leave, system prompted an error: This leave does not have any approver. Why is this happened as I have set the approval setting?

Error NoApprover 1.png


Possible Reason :

1. This employee is assigned to a newly created departments/sub-department which was not included in Leave Approval setting.

2. Leave approver setting is for number of days ranging from 1.0 but the employee is applying for half day leave (0.5 day).


Solution 1:

Edit the Leave Approval setting to include the new departments if your company practises one approver to approve all employees’ application.

1) Go to Tools > User Setting > Approval Setting. Click on Edit button.

Error NoApprover 2.png


2) Check to select departments and/or sub-departments then click on Save.

Error NoApprover 3.png


OR Create/add a new leave approval if your company practises different approvers to approve different departments.

1) Go to Tools > User Setting > Approval Setting. Click on Add New button.

Error NoApprover 4.png


2) Check to select departments and/or sub-departments then click on Save.

Error NoApprover 5.png



Solution 2:

1) Go to Tools > User Setting > Approval Setting. Click on Edit button.

2) Change the Range From Day to 0 then click on Save button.

Error NoApprover 6.png



Note: Same solution applies to Claim Approver Setting.


By : Aisyah 181108, Lay Swan 181213, P181214
Updated by Aisyah 200713, Azirah 200714, P200727


Go to menu

IconAcc20.PNG AutoCount Accounting 2.0


IconAcc188.PNG AutoCount Accounting 1.8 / 1.9
Wiki-Payroll.png AutoCount Payroll
Wiki-POS.PNG AutoCount POS


Wiki-AOTG.PNG AutoCount On The Go
Wiki-Accounting-Plugin.png AutoCount Accounting Plug-In Documentations