Cloud Payroll - Error “This leave does not have any approver” when employee apply E-Leave

From AutoCount Resource Center
Jump to navigation Jump to search

Question :AA use E-leave to apply leave, system prompted an error: This leave does not have any approver. Why is this happened as I have set the approval setting?

Error NoApprover 1.png


Possible Reason :

1. This employee is assigned to a newly created departments/sub-department which was not included in Leave Approval setting.

2. Leave approver setting is for number of days ranging from 1.0 but the employee is applying for half day leave (0.5 day).


Solution 1:

Edit the Leave Approval setting to include the new departments if your company practises one approver to approve all employees’ application.

1) Go to Tools > User Setting > Approval Setting. Click on Edit button.

Error NoApprover 2.png


2) Check to select departments and/or sub-departments then click on Save.

Error NoApprover 3.png


OR Create/add a new leave approval if your company practises different approvers to approve different departments.

1) Go to Tools > User Setting > Approval Setting. Click on Add New button.

Error NoApprover 4.png


2) Check to select departments and/or sub-departments then click on Save.

Error NoApprover 5.png



Solution 2:

1) Go to Tools > User Setting > Approval Setting. Click on Edit button.

2) Change the Range From Day to 0 then click on Save button.

Error NoApprover 6.png



Note: Same solution applies to Claim Approver Setting.


By : Aisyah 181108, Lay Swan 181213, P181214
Updated by Aisyah 200713, Azirah 200714, P200727


Go to menu

IconAcc20.PNG AutoCount Accounting 2.0


IconAcc188.PNG AutoCount Accounting 1.8 / 1.9
Wiki-Payroll.png AutoCount Payroll
Wiki-POS.PNG AutoCount POS


Wiki-AOTG.PNG AutoCount On The Go
Wiki-Accounting-Plugin.png AutoCount Accounting Plug-In Documentations