Accounting 2.0 - Prompted Message: Error during upgrade to 2.0-Error while installing SQL functions and Stored Procedures

From AutoCount Resource Center
Jump to navigation Jump to search

Question : When upgrade database from 1.9 to version 2.0, error message prompted: Error while installing SQL functions and Stored Procedures…. Why?

Upgrade sql error1.png


Possible Reason :

You are using older SQL Server version such like SQL 2005.


Solution :

For AutoCount Version 2.0, the requirement for SQL Server is SQL Server 2012 or above.

You need to upgrade your current SQL server to SQL Server 2012 or above. After that, please login to complete the upgrade of database.

Upgrade sql error2.png


If you do not wish to upgrade the current SQL server, you may install SQL Server 2012 in another instance name, restore your database to the new SQL instance, then upgrade this new restored book to Version 2.0.


Note : Please seek assistance from your software dealer if the problem still persists after performing the suggested steps.


By : Tan 200316, Lay Swan 200323, P200324


Go to menu

IconAcc20.PNG AutoCount Accounting 2.0


IconAcc188.PNG AutoCount Accounting 1.8 / 1.9
Wiki-Payroll.png AutoCount Payroll
Wiki-POS.PNG AutoCount POS


Wiki-AOTG.PNG AutoCount On The Go
Wiki-Accounting-Plugin.png AutoCount Accounting Plug-In Documentations