Troubleshooting: Attach account book error-Unknown Sql Exception, The database ‘AED TEST’ cannot be opened because it is version 706.

From AutoCount Resource Center
Jump to navigation Jump to search

Question: When I try to attach an account book, an error message 'Unknown Sql Exception, the database ‘AED_TEST’ cannot be opened because it is version 706. This server supports version 663 and earlier. A downgrade path is not supported. ' prompted?

Version: 1.8 / 1.9 / 2.0

Version 706.png


Possible Reason:

You are trying to attach a database that is from a higher or newer version of SQL Server than your current device’s SQL Server.


Solution:

You will need to check the version of SQL Server that previously host this database, and then install the same or higher version of SQL Server in order to attach the database.

Steps to check the version of SQL Server:

1. Run SQL Server Configuration Manager. You can find this tool by using Windows Search function.

2. Look for your SQL Server services and find the instance A2006 (usually AutoCount pre-installed using namespace A2006)


Version 706 1.png


3. Right click on this service (A2006) and click Properties.

4. Look for Advanced Tab and scroll down to Version.


Version 706 2.png


5. You can see there is a version number there. Different version number represent different version of SQL Server. List of version number patterns and database versions can be found as below:


Version 706 3.png


By JS 170630, CY 170814, KM 170814. P170815

Go to menu

IconAcc20.PNG AutoCount Accounting 2.0


IconAcc188.PNG AutoCount Accounting 1.8 / 1.9
Wiki-Payroll.png AutoCount Payroll
Wiki-POS.PNG AutoCount POS


Wiki-AOTG.PNG AutoCount On The Go
Wiki-Accounting-Plugin.png AutoCount Accounting Plug-In Documentations